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6i RELEASE PROCESSES AND PROCEDURES

1. Purpose

The DCD/DCW 6i Release Processes and Procedures (6iRPP) document specifies process and procedures for managing releases in the Oracle Designer 6i environment.  It ensures that activities are planned; changes to identified software work products are controlled; and affected groups and individuals are informed of the status and content of the DCD/DCW software releases at each phase of the lifecycle.  The DCD/DCW 6iRPP provides detailed guidance for managing release configurations and workareas within the Oracle Designer 6i environment, in accordance with the objectives of the DCII Software Configuration Management Plan.  The objectives of the DCD/DCW 6iRPP are as follows:

· Provide information on the roles and responsibilities of the different offices involved in creating a DCD/DCW release
· Provide information on the tasks involved in developing a release

· Provide detailed desk procedures on accomplishing the required tasks
2. Scope

This document addresses the responsibilities and procedures for developing DCD/DCW releases in the Oracle Designer 6i Software Configuration Manager/Repository (SCM/Repository).  It encompasses the creation and maintenance of release specific configurations; identifying release baselines; and the creation and maintenance of analysis, development, test and production workareas.  

3. General Information

Containers (applications and folders) will only be checked-out if new primary objects need to be added to the container.  Containers may remain checked out during the development process to help lessen the number of container versions. 

Release configurations created in the repository will always be created and versioned utilizing the Designer Configuration Wizard available through the Repository Object Navigator (RON). Configurations will always be checked-in to the MAIN branch.  The first version (1.0) of all configurations will always be created and checked-in as empty.

Whenever any object is checked-out, information will be included in the checkout ‘Notes’ field explaining why the object was checked-out.  When objects are checked-in, either include a short summary of the change in the ‘Notes’ field, or use the checkout notes.  Examples of ‘Notes’ would be the SCR or TDR number; or, use the release name if the specific SCR isn’t known yet (only applies to preliminary functional analysis).  If the release isn’t known yet, summarize the change made to the object (such as, “Attribute XX added to support new requirements”.)  Checkout/check-in “notes” will be completed for all versionable objects; application and folder containers, configurations, and primary access components (e.g. entities, domains, tables, modules, etc.)  If no changes are made to a checked-out object, an “undo checkout” should be performed instead of a check-in; see appendix B for instructions.

The DCII Configuration Management/Release Management (CM/RM) Team will create four empty configurations for each release, functional, development, SIT and E*T.  The Functional Configuration Manager (FCM) has the responsibility for managing the functional configuration, the Technical Configuration Manager (TCM) is responsible for managing the development configuration, and the DCII CM/RM Team is responsible for managing the SIT and E*T configurations.  The FCM and TCM are members of the Functional and Technical teams and will be appointed by the Functional Point of Contact (FPOC) and Technical Project Officer (TPO).

To make the creation and modification of development workareas as quick and simple as possible, the FPOC or TPO should utilize workarea specification files as much as possible, especially when requesting CM/RM assistance. 

There is a standard default access for all DFAS Corporate Database (DCD)/DFAS Corporate Warehouse (DCW) containers, configurations and workareas.  The standard default access has been established to ensure that everything is visible to everyone with repository access and that the Repository Management (DCDADMIN) and Release Management (RELADMIN) have all access required for the administrative work they perform.  DCDADMIN and RELADMIN will be granted Administrate, Insert, Update, Delete and Version to all containers and configurations created; DCDADMIN and RELADMIN will be granted Administrate, Insert, Update, Delete, Version, Compile and Update Spec to all workareas created; and PUBLIC will be granted SELECT to all containers, configurations and workareas created.

For FCMs and TCMs to manage configurations and workareas, the FPOC and TPO must send an email to the Repository Manager requesting the ‘Allow management of workareas and configurations’ repository privilege be granted to those individuals  identified as the FCM/TCM.  If the FPOC and TPO will also be managing workareas and configurations they should include their own names with the request.

Documentation related to the release, such as review checklists, audit checklists and minutes, can be uploaded to the repository and added to the release configuration.  If a soft copy of the documents is not available, a hardcopy of the document will be scanned and the scanned copy uploaded into the repository.

4. Specific Processes and Procedures

4.1. Beginning Analysis on A New Release

4.1.1 Create release branch 

When the Functional Point of Contact (FPOC) is ready to begin work on a new release, the FPOC will:

· Submit an email to CM/RM (email address is “DCII-Release Manager”) to request new release branch be created

· Submit an email to Repository Management (email address is “Repository Manager”) and include:

· Completed 6i Repository Container/Workarea Request Form to request creation of a new release documentation folder and required functional sub-folders.  The new release folder will be a subfolder under DCD_Release_Documentation_FLD (may be DCW_…) and use the 6i Repository Naming Standard. 

· Completed 6i Repository User Access Request Form to grant FCM, FPOC and functional analysts appropriate access to the new release folder. 

CM/RM will create the new branch using the 6i Repository Naming Standard. 

4.1.2 Create release documentation folder

Repository Management:

· Creates the new sub-folder(s)

· Grants the standard default access

· Grants the requested access 

· Notifies FPOC via email that requested actions are complete

4.1.3 Create release configuration

CM/RM:

· Creates the new EMPTY release configurations using the 6i Repository Naming Standard 

· Grants the standard default access to the configurations 

· Grants full access (Insert, Update, Delete, Version) to the functional configuration to the FPOC and FCM 

· Grants full access (Insert, Update, Delete, Version) to the development configuration to the TPO and TCM 

· Notifies the FPOC, TPO, FCM and TCM via email that the release branch and configurations have been created

4.1.4 Create release workareas

FPOC may furnish CM/RM with initial specifications for the functional analysis workarea.

CM/RM:

· Creates the functional analysis and technical development release workareas using the 6i Repository Naming Standard 

· Establishes the default check-in branch for the workareas as the new release branch

· If specifications have been provided uses those to create the workareas, else the workareas are created as empty (see detailed procedures)

· Grants the standard default access to the workareas 

· Grants full access (Insert, Update, Delete, Version, Compile, Update Spec) to the functional workarea to the FPOC and FCM 

· Grants full access (Insert, Update, Delete, Version, Compile, Update Spec) to the development workarea to the TPO and TCM 

· Notifies the FPOC, TPO, FCM and TCM via email that the workareas have been created

4.1.5 Functional Analysis

The FPOC and FCM manage the functional analysis phase of the release life cycle.  If the FCM is unavailable, the FPOC may request the assistance of CM/RM to perform any of the following:

· Versioning the functional configuration to add and remove objects required for the release. 

· Editing workarea specifications

· Refreshing workarea

· Granting workarea access to functional analysts

4.1.6 Functional Requirements Review/Configuration Control Board

Immediately after the Functional Requirements Review (FRR)/CCB, the FPOC/FCM:

· Ensures a list of all functional referential objects required for the release (and included in the functional configuration) is either uploaded to the Release Documentation folder in the repository or attached to an SCR approved for the release

· Versions the functional configuration to include final corrections, ensuring the functional configuration check-in “Notes” reflect that this version of the functional configuration is the functional baseline

· Sends an email to CM/RM, and the TPO that the functional requirements are ready for technical design/analysis and development, identifying the version of the functional configuration to be used for development

Prior to the FRR/CCB the TPO should be monitoring the functional configuration and coordinating with functional analysts.  If there is a problem with the configuration, such as functionality being incomplete for technical development, the TPO should coordinate with the functional analysts to work it out.  If a solution isn’t arrived at when the FRR/CCB are scheduled, the TPO must notify the DCII Technical Project Officer (TPO) prior to the FRR/CCB that there are unresolved issues with the release.

4.1.7 Additional/Modified Functional Requirements 

As functional analysts identify new requirements for the release they will continue to work these in the functional release workarea.  The FPOC must continue to coordinate the new/modified release requirements with the TPO.  As the object versions for the new requirements are identified and approved through the FRR/CCB process, the FCM will add the new object versions to a new version of the functional configuration.

When all objects in the new version of the functional configuration have been approved by the CCB (some objects may have been approved by a previous CCB), the FPOC will notify CM/RM and the TPO that a newer version of the functional configuration has added or modified functionality which needs to be developed for the release.

The TPO should be monitoring the new/modified requirements and coordinating with the functional analysts.  If there is a problem with the new requirements, the TPO should coordinate with the functional analysts to work it out.  If a solution isn’t arrived at when the FRR is scheduled, the TPO must notify the DCII Technical Project Officer (TPO) prior to the FRR/CCB that there are unresolved issues with the release.

4.2 Technical Design, Analysis and Development

4.2.1 Acceptance of functional configuration for technical development

CM/RM:

· Emails a request to the CMIS Administrator requesting a report on all SCRs and the attached CIs for the working release

· If a previous version of the functional configuration for the release is already in development, CM/RM compares the new version to the previous version and identifies all differences.  The following three steps will only apply to identified new or changed versions of objects

· Uses the CMIS report to ensure all new or changing objects have approved SCRs in CMIS, and that the SCRs are attached to the correct release

· Reviews the documentation listing the release referential objects to ensure only those listed are included in the identified functional configuration version 

· If any listed objects, SCR or referential, are missing from the configuration, or if any objects are in the configuration but not in an SCR or on the referential list, notifies the FPOC, FCM, TPO and the DCII TPO of the discrepancy and requests it be corrected within 24 hours

4.2.2 Technical Analysis, Design and Development

When all objects in the functional configuration have been confirmed as either a CI on an approved release SCR or listed as a referential object, CM/RM sends an email to the TPO, TCM and the DCII TPO.  The email notifies them that the objects in the identified functional configuration version have been verified and they can continue with the analysis, design and development.  If the functional configuration version is a change to a previous version, CM/RM will include the list of differences from the compare.

The TPO and TCM manage the technical analysis, design and development phases of the release life cycle.  If the TCM is unavailable, the TPO may request the assistance of CM/RM to:

· Version the development configuration to add and remove objects required for the release. 

· Edit workarea specifications

· Refresh workarea

· Grant workarea access to technical developers

An example of the specifications for a development workarea is:


Include_Config (DCD_FUNC_XS0304_CFG(MAIN;3)=Configuration)


Latest (DCD_XS0400_BR)


Latest (DCD_XS0308_BR)


Include_Folders (System Folder(MAIN;1)=Folder)

Or, if you need to include the Latest on MAIN:


Include_Config (DCD_FUNC_XS0400_CFG(MAIN;3)=Configuration)


Latest (DCD_XS0400_BR)


Latest (DCD_XS0308_BR)


Latest (MAIN)


Exclude_Folder (DCII_Corp_Dev_Tool_Set_App(MAIN;2)=Application System)


Exclude_Folder (DCW_Baseline_App(MAIN;3)=Application System)


Exclude_Folder (DDRS_IPS_APP(MAIN;2)=Application System)

Or, if you know which development objects are needed (after CDR):


Include_Config (DCD_FUNC_XS0400_CFG(MAIN;3)=Configuration)


Latest (DCD_XS0400_BR)


Include_Config (DCD_DEV _XS0400 _CFG(MAIN;2)=Configuration)


Include_Folders (System Folder(MAIN;1)=Folder)

4.3 SYSTEM INTEGRATION/FUNCTIONAL VALIDATION TESTING (SIT)

The DCII-Integration Team coordinates with TPOs, DBAs, Test Directors and CM/RM on the schedule and status of each test phase. 

When development and unit testing are complete, the TPO will:

· Ensure the development configuration contains the correct version of all technical objects required for the release (new, modified and referential)

· Notify CM/RM by email that the release is ready for testing, identifying the version of the development configuration that is ready for SIT and the version of the functional configuration that development has been completed for.

4.3.1 Create “readme” and Application Release Checklist (ARC)

The segment (DSDS, CEFT, FICS, etc) TPO will prepare the necessary “readme” file(s) and the ARC, then email to the DCII Integration Team for review and coordination with a ‘cc’ to DCII-Release Manager.  The ARC and Readme will be stored in the DCD_NonGen_FLD container by release and environment being built.

If multiple segments are involved in the release, the Integration Team will create an additional Integration ARC which contains the overall instructions for creation of the test environment and the order in which to apply the segment ARCs.  They then email all ARCs and consolidated “readme” files to CM/RM for processing.

4.3.2 Update SIT configuration 

CM/RM:

· Emails a request to the CMIS Administrator requesting a report on all SCRs and the attached CIs for the working release

· Uses the CMIS report to ensure all new or changing objects have approved SCRs in CMIS, and that the SCRs are attached to the correct release

· Reviews the documentation or SCRs listing the release referential objects to ensure only those listed are included in the configurations

· If any listed objects (SCR or referential) are missing from the configurations, or any objects are in the configurations but not in an SCR or on a referential list, notifies the FPOC, FCM, TPO, TCM and the DCII TPO of the discrepancy and requests it be corrected within 24 hours

· Adds the objects in the identified versions of the functional and development configurations to the SIT configuration to create the initial SIT baseline for the release

4.3.3 Create and Maintain SIT Review/Generation Workarea

CM/RM:

· Creates a SIT Review/Generation workarea using the 6i Repository Naming Standard.  The workarea should be set up like the following example.  The name/rules will vary depending on the release being worked.

WORKAREA SPECS for SIT Review:


Name:

DCD_ SIT_REVIEW_GEN _ XX9999 _WA


Branch:
None


Rules:

DCD_SIT _XX9999 _CFG (MAIN;Latest Version #)

View:
All functional and technical objects considered part of the release or needed to generate the release objects

· Grants the standard default access to the SIT review workarea.  

· Edits the workarea specifications each time the configuration is updated with a TDR fix

· Refreshes the workarea each time the configuration is updated so the current test objects are visible

The Generation Team uses the SIT Review/Generation workarea to generate the SIT environment and all modifications made to the environment when processing TDR fixes.

4.3.4 Object Generation and Environment Build 
The CM/RM Generation Team:

· Generates all objects required to build or update the test environment from the Test Review/Generation Workarea based on the documented generation procedures 

· Emails the ARCs, “readmes” and location of the generated objects  to the DBAs to build the test database environment

DBAs notify the DCII-Integration Team when the test environment has been successfully built.

DCII-Integration Team notifies the Test Director that the test environment is ready

4.3.5 Testing

Testers may upload test documents to the Release Documentation folder in the repository.

4.3.6 TDR Changes 
The testers report TDRs as they occur during testing in accordance with their test/TDR procedures.

The development team:

· Fixes objects identified in TDRs within the release development workarea

· Emails the TDR “readme” file to CM/RM identifying the corrected object versions

CM/RM:

· Updates the SIT configuration to include updated versions of corrected objects identified in the TDR “readme”

· Updates and refreshes the Test Review/Generation workarea 

· Generates the objects identified in the TDR “readme” 

· Emails the “readme” and location of the generated objects  to the DBAs to modify the test database environment

DBAs notify the DCII-Integration Team when the test environment has been successfully updated.

DCII-Integration Team notifies the Test Director that the TDR fix has been added to the test environment.

4.4 ENTERPRISE IMPLEMENTATION/ACCEPTANCE/PERFORMANCE TESTING (E*T)

The DCII-Integration Team notifies CM/RM when to begin the build for E*T.

4.4.1 Create “readme” and Application Release Checklist (ARC)

The segment (DSDS, CEFT, FICS, etc) TPO will prepare the necessary “readme” file(s) and the ARC, then email to the DCII Integration Team for review and coordination with a ‘cc’ to DCII-Release Manager.  The ARC and Readme will be stored in the DCD_NonGen_FLD container by release and environment being built.

If multiple segments are involved in the release, the Integration Team will create an additional Integration ARC which contains the overall instructions for creation of the test environment and the order in which to apply the segment ARCs.  They then email all ARCs and consolidated “readme” files to CM/RM for processing.

4.4.2 Update E*T configuration 

CM/RM:

· Emails a request to the CMIS Administrator requesting a report on all SCRs and the attached CIs for the working release

· Uses the CMIS report to ensure all new or changing objects have approved SCRs in CMIS, and that the SCRs are attached to the correct release

· Reviews the documentation or SCRs listing the release referential objects to ensure only those listed are included in the configurations

· If any listed objects (SCR or referential) are missing from the latest SIT configuration, or any objects are in the configuration but not in an SCR or on a referential list, notifies the FPOC, FCM, TPO, TCM and the DCII TPO of the discrepancy and requests it be corrected within 24 hours

· Adds the objects in the latest version of the SIT configuration to the E*T configuration to create the initial E*T baseline for the release

4.4.3 Create and Maintain E*T Review/Generation Workarea

CM/RM:

· Creates an E*T Review/Generation workarea using the 6i Repository Naming Standard.  The workarea should be set up like the following example.  The name/rules will vary depending on the release being worked.

WORKAREA SPECS for E*T Review:


Name:

DCD E*T_REVIEW_GEN _ XX9999_ _WA


Branch:
None


Rules:

DCD_E*T _XX9999 _CFG (MAIN;Latest Version #)

View:
All functional and technical objects considered part of the release or needed to generate the release objects

· Grants the standard default access to the E*T review workarea.  

· Edits the workarea specifications each time the configuration is updated with a TDR fix

· Refreshes the workarea each time the configuration is updated so the current test objects are visible

The Generation Team uses the E*T Review/Generation workarea to generate the E*T environment and all modifications made to the environment when processing TDR fixes.

4.4.4 Object Generation and Environment Build 
The CM/RM Generation Team:

· Generates all objects required to build or update the test environment from the E*T Review/Generation Workarea based on the documented generation procedures 

· Emails the ARCs, “readmes” and location of the generated objects  to the DBAs to build the test database environment

DBAs notify the DCII-Integration Team when the test environment has been successfully built.

DCII-Integration Team notifies the Test Director that the test environment is ready

4.4.5 Testing

Testers will upload test documents to the Release Documentation folder in the repository.

4.4.6 TDR Changes 
The testers report TDRs as they occur during testing in accordance with their test/TDR procedures.

The development team:

· Fixes objects identified in TDRs within the release development workarea

· Emails the TDR “readme” file to CM/RM identifying the corrected object versions

The TPO/TCM update the development configuration to include the updated versions of corrected objects.

CM/RM:

· Updates the E*T configuration to include updated versions of corrected objects identified in the TDR “readme”

· Updates and refreshes the Test Review/Generation workarea 

· Generates the objects identified in the TDR “readme” 

· Emails the “readme” and location of the generated objects  to the DBAs to modify the test database environment

DBAs notify the DCII-Integration Team when the test environment has been successfully updated.

DCII-Integration Team notifies the Test Director that the TDR fix has been added to the test environment.

4.5. PRoduction

The DCII-Integration Team notifies CM/RM when to begin the build for Production.

The segment (DSDS, CEFT, FICS, etc) TPO will prepare the necessary “readme” file(s) and the ARC, then email the “readme” file(s) and the ARC to the DCII Integration Team for review and coordination

If multiple segments are involved in the release, the Integration Team will create an additional Integration ARC which contains the overall instructions for creation of the test environment and the order in which to apply the segment ARCs.  They then email all ARCs and consolidated “readme” files to CM/RM for processing.

CM/RM:

· Versions the E*T release configuration and identifies this as the production build version
· Creates a Production Generation workarea using the 6i Repository Naming Standard.  The workarea will be set up like the following example.  The name/rules will vary depending on the release going to production.
WORKAREA SPECS for Production Generation:


Name:

DCD_ PROD_GEN_XX9999_WA


Branch:
None


Rules:

DCD_E*T _XX9999 _CFG (MAIN, Latest)


View:

Functional objects, technical objects and any existing 




documentation considered part of the release

· Grants the standard default access to the production generation workarea

CM/RM performs a Physical Configuration Audit (PCA) with the assistance of the DCII Integration Team to ensure the correct objects are included in the production baseline release configuration.

The Integration Team:

· Emails a request to the CMIS Administrator requesting a report on all SCRs and the attached CIs for the working release and forwards the report with the “readme” file(s) and ARC(s) to CM/RM for processing

· Compares the object versions in the ARC with object versions in the “readme” file(s) and between the “readme” files to ensure they are all the same.

· CM/RM:

· Runs the configuration list script to create a report identifying all objects in the production build configuration by name and version.  Report also has three additional columns to identify whether the object is on either an approved SCR or on a referential object list, and whether it matches the object version listed in the “readme” files.

· Compares the CMIS report to the configuration list to ensure all new or changing objects have approved SCRs in CMIS, and that the SCRs are attached to the correct release.  Checks off the ‘SCR’ column on the configuration list.  

· Compares the SCR object versions identified in the “readmes” and ARCs to the object versions in the configuration list to ensure they’re the same.  Checks off the ‘MATCH README’ column, if the versions agree.

· Compares the referential objects listing in the repository to the configuration list to ensure only those listed are included in the E*T configuration.  Checks off the ‘REF’ column on the configuration list.  

· Runs the production configuration compare script to compare the version of the object in production to the version in the E*T configurations production build version.  Objects already existing in production must have an older version than the same object in the E*T configuration

· If there are any discrepancies noted in any of the compares, notifies the Integration Team of the discrepancy.  

· The Integration Team forwards notification of the discrepancy to the appropriate TPOC, TCM, developer and requests it be corrected within 24 hours.

· CM/RM:

· Runs the configuration functional compare script to create a report listing differences in functional objects between the final approved functional configuration version and the E*T configuration’s production build version.  If there are any differences, notifies the FPOC, FCM, TPOC, TCM and the DCII TPO of the discrepancy and requests instructions on whether to continue with the production build

· Adds Release Documentation sub-folder to the release configuration

· Release will not go to production build until all discrepancies have been resolved 

4.5.1 Implementation and Deployment

The CM/RM Generation Team:

· Generates all objects required to build/modify the production environment from the Production Generation Workarea based on documented generation procedures  

· Emails the ARCs, “readme” files and location of the generated objects to the DBAs, with a copy to PSO.  The DBAs will deploy the updates to the production environment after approval by PSO.

CM/RM:

· Creates the release letter based on sample.

· Emails the release letter to the DCII-Release-Notification distribution list

· Uploads the release letter into the release documentation sub-folder in the repository

· Versions the E*T production build configuration to include the release letter.  Check-in notes will be included that this is the production baseline version of the E*T configuration.

· Versions the production configuration and adds the new objects and new object versions for the release

· Updates the production AR workarea to view the new version of the production configuration

· Deletes the TDR, test and generation workareas for the release

The TPOC or the TCM:

· Utilizes the Version History Viewer in the RON and checks each object in the E*T production build configuration to see if it was branched off before the final version in the E*T production build configuration.  

· As needed, merges the final version of the objects to future release branches, in coordination with TCM and other release TPOCs, so any changes/corrections made during final testing are rolled forward to future releases.

4.5.2 Maintenance
CM/RM:

· Creates a Production AR workarea using the 6i Repository Naming Standard.  The workarea should be set up like the following example. 

WORKAREA SPECS for ARs:


Name:

DCD_ PROD_ AR _WA


Branch:
None


Rules:

DCD_PRODUCTION_CFG (MAIN, Latest)


View:

Functional objects, technical objects and any existing




documentation required to rebuild the production environment

· Grants requested workarea access to technical developers

· Updates the workarea specifications 

· Refreshes the  workarea as needed and in coordination with the TPO to insure any ongoing changes are not lost

The TPO:

· Identifies developers who need Insert, Update and Version access to the Production AR workarea for working ARs

· Submits the 6i Repository User Access Request Form to CM/RM to request any changes to access to the Production AR workarea

The development team:

· Fixes objects identified in ARs within the Production AR workarea

· Emails the AR “readme” file to CM/RM identifying the corrected object versions

The CM/RM Generation Team:

· Confirms the object versions identified in the “readmes” are correct

· Confirms a remedy ticket or an approved SCR exists for the change

· Generates identified modification objects from the AR Workarea based on documented generation procedures 

· Emails the “readmes” and location of the generated objects  to the DBAs 

· Updates the configuration based on modification “readmes”

The DBAs will run the scripts to make the production modifications.

As needed, the TPO or TCM merge the corrected AR objects to future release branches, in coordination with other release TPOs.

5. Procedures For Updating Processes And Procedures 

The DCII DCD/DCW 6iRPP is maintained on the shared drive, \\ISO-FS-N-1\DATA\dcii-shared\Plans\6i_Rel_Proc.doc; a copy will also be maintained under the DCD_Release_Documentation_Fld in the repository.  The DCII CM/RM, DCII TPO, DCD/DCW FPO and TPO are responsible for monitoring and approving the 6iRPP.  Updates to the 6iRPP will occur as necessary to reflect current processes and procedures.  The DCD/DCW CM/RM, at the request of the DCII TPO, makes changes to the process and procedures.  Comments and or suggestions for improvement to this document should be addressed to the DCII Configuration Manager.

6. Change Information Sheet

I certify that the 6i Release Processes and Procedures document for DCD/DCW has been reviewed and is consistent with management objectives for this project.

_________/ S /___________________

Date:  __6/20/03_______

Bill Farison, DCII Configuration Manager

_________/ S /___________________

Date:  __6/20/03_______

Nancy Moore, DCII TPO
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Appendix A

Roles and Responsibilities

DCD/DCW Configuration/Release Management (CM/RM)

· Creates release branches

· Creates release configurations

· Creates workareas

· Manages release configurations from SIT through the remainder of the release lifecycle

· Grants access to workareas for test review, TDR and AR fixes

· Conducts baseline audits prior to each test phase and production 

· Generates objects required to build or update test or production environments

· Coordinates and facilitates release of objects with DBAs

· Creates and distributes the “release letter”

· Assists the Functional and Technical Configuration Managers and POCs with maintaining workareas and release configurations

· Maintains DCII SCRs using CMIS 

· Maintains all DCD/DCW configuration and release management plans and procedures

Functional Point of Contact (FPOC)

· Requests CM/RM create new release branch, workarea and configuration

· Appoints the Functional Configuration Manager (FCM)

· Notifies FCM who to grant workarea access to

· Coordinates with FCM to identify objects affected by the release

· Sets up FRR and CCB

· Ensures all objects created or modified for the release meet all DCII standards

· Ensures release configuration correctly defines functional requirements of the release prior to the CCB

Functional Configuration Management (FCM)

· Manages functional analysis workareas

· Manages functional configurations 

· Checks-out/checks-in functional objects required for analysis

· Checks-out application container when needed to add new functional objects

· Checks-in, or merges, application container coordinating with other FCMs to avoid losing objects

· Ensures that prior to CCB all objects are checked-in

 Technical Point of Contact (TPOC)

· Appoints the Technical Configuration Manager (TCM)

· Notifies TCM which developers to grant workarea access to

· Decides who (if any) of the development staff will be given version access.

· Coordinates with lead developers to identify all objects affected by the release.

· Sends list of release objects to TCM to add to the release configuration

· Sets up CDR

· Ensures all objects created or modified for the release meet all DCII standards

· Ensures release configuration includes the correct version all objects required for the release prior to SIT

· Prepares necessary “readmes” and ARC

Technical Configuration Management (TCM)

· Manages development workareas

· Manages development configurations 

· If required, checks-out/checks-in technical objects required for development

· Checks-out application container when needed to add new technical objects

· Checks-in, or merges, application container coordinating with other Technical Configuration Managers to avoid losing objects

· Ensures that prior to SIT all objects are checked-in

Appendix B

Detailed Procedures

Index of Procedures:
Page Number

Access

Grant/Remove Access to a Configuration
22

Grant/Remove Access to a Workarea
26

Branches

Create a New Branch
21

Compares

Comparing different versions of an object
33

Comparing different versions of a configuration
33

Comparing different objects
34

Configurations

Create an Empty Configuration
21

Grant/Remove Access to a Configuration
22

Version and Modify a Configuration based on specific requests
28

Version and Modify a Configuration based on a Workarea
29

Version and Modify a Configuration based on the latest version of 

     each object in the configuration
30

Confirm authorization 
21

Merging objects

Merging Objects
34

Versioning objects

Check-out objects
26

Check-in objects
27

Check-in objects with merge
27

Undo Checkout of objects
28

Workareas

Create an Empty Workarea
22

Create a Workarea based on a Configuration
24

Create a Workarea based on a Specification File
25

Create a Workarea based on a list of Specifications
23

Create a Workarea specification file manually
24

Create a Workarea specification file from an existing Workarea
26

Grant/Remove Access to a Workarea
20

Edit Workarea Rules and Specifications based on specific requests
30

Edit Workarea Rules and Specifications based on a Specification File
32

Refresh a Workarea
32

Confirm authorization to request workarea changes, access or object checkout/check-in

1. The Workarea and Configuration POC list is in the DCII-Release Manager inbox, 6I Issues/POC Lists folder as an email with subject POC.xls

2. The container (application and folder) POC list is at k:\shared\dcii\dciirepm\Poc list.xls

3. If the requestor’s name is shown in the appropriate column/row based on the container/workarea, process the request

4. If the requestor’s name is not present, return the request to the sender and have them submit it through an appropriate POC.  For their convenience, the POC list is posted in the DCII Weekly Bulletin

Create a New Branch:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Version’ menu, ‘Edit Branch Labels…’

3. Click the ‘Add’ button

4. Type the correct branch name in the ‘Label’ field

5. Put the use of the branch in the ‘Notes’ field

6. Click ‘OK’

7. Click ‘Close’ to close the ‘Branch Labels’ window

Create an Empty Configuration:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Configuration Wizard…’

3. In the Welcome Window, select ‘Create a New Configuration’

4. Type in the Configuration Name 

5. Type in a description of the use of the Configuration; will usually be to identify objects in a specific release

6. Click ‘Next’

7. In the Options Window, select ‘Create a Custom Configuration’

8. Select ‘Just select objects from the repository’

9. Click ‘Next’

10. In the Members Window, click ‘Next’

11. In the External References Window, click ‘Next’

12. In the Save Window, select ‘Save and check in configuration’

13. Click ‘Next’

14. Type in ‘Check-in Notes’; will usually be “Empty configuration created to begin a new release”

15. Click ‘OK’

16. In the Summary Window, click ‘Finish’

Grant/Remove Access to a Configuration:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open’

3. Click the ‘Up One Level’ button (yellow folder with up arrow) until the word ‘Repository’ shows in the Navigator window

4. Select ‘Repository’

5. Click ‘OK’

6. Expand the ‘Configuration’s’ list (press the ‘+’)

7. Select the correct configuration (access applies to all versions)

8. Select the ‘File’ menu, ‘Access Rights’, ‘Grant Access Rights …’

9. Select the user to provide access to (hold down the ‘Ctrl’ or ‘Shift’ key to select multiple names)

10. To grant access, check the correct boxes in ‘To Grant’ for the access being granted

11. Click ‘Grant’

12. To remove access, check the correct boxes in ‘To Revoke’ for access being removed

13. Click ‘Revoke’

14. Click ‘OK’

Create an Empty Workarea:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Workarea Wizard …’

3. In the Default window, select ‘Create a custom workarea’

4. In the Customize window, type in the workarea name 

5. Type in the description of what the workarea will be used for

6. Click ‘Next’

7. In the Default Check in Branch window, if a default check-in branch has been requested, select the correct branch name by clicking on it once  [NOTE: If no default check-in branch is selected, objects are checked-in to the branch from which they were checked-out]

8. Click ‘Next’

9. In the Rules Specification window, click ‘Edit …’ button

10. Select the rule from on the right side of the window, then click the left pointing arrow button in the middle of the ‘Edit Specification’ window to empty the specification list.

11. Click ‘OK’

12. Click ‘Finish’

Create a Workarea based on a list of specifications:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Workarea Wizard …’

3. In the Default window, select ‘Create a custom workarea’

4. In the Customize window, type in the workarea name 

5. Type in the description of what the workarea will be used for

6. Click ‘Next’

7. In the Default Check in Branch window, if a default check-in branch has been requested, select the correct branch name by clicking on it once  [NOTE: If no default check-in branch is selected, objects are checked-in to the branch from which they were checked-out]

8. Click ‘Next’

9. In the Rules Specification window, click ‘Edit …’ button

10. On the ‘Rules’ subtab, select the correct Rule from the drop down box.  The FPOC or TPO requesting the action must provide the rules and all parameters for them.  The rules available, and their parameters are:

· Exclude Folder – Folder Path

· Exclude Object – Object Path

· Include Folder – Folder Path

· Include Object – Object Path

· Folder Latest Contents – Folder Path, Branch Label

· Latest – Branch Label

· Latest config contents – Branch Label, Configuration

· Folder Latest Before – Folder Path, Before Date

· Folder Latest Between – Folder Path, Start Date, End Date

· Latest Before – Branch Label, Before Date

· Latest Between – Branch Label, Start Date, End Date

· Latest Diagram Contents – Diagram Path, Branch Label

11. Select (click on) the correct rule, and use the ‘Browse’ buttons to locate the correct parameters required for that rule.

12. For Folder, Object and Diagram Path parameters, clicking the ‘Browse’ button brings up a ‘Select folder/object/diagram Path:’ window.  By default, this window only displays what’s in the current workarea.  To look in a different workarea or container: At the top middle of the window is a button with a yellow folder and an upward pointing arrow on it.  Click on this button to go up one level in the repository structure, keep clicking until you see the selection list displaying Private Workareas, Shared Workareas, Configurations, All Containers.

13. Depending on whether you’re looking in a workarea or a specific version of a container for your object, double click on that selection (the FPOC/TPOC should identify exactly where to find the objects they want to include).

14. Keep double clicking on the appropriate workarea, and then containers until you get to the level you need to find the correct object.

15. Select the identified object with a single click, then click ‘OK’

16. On the ‘Configurations’ subtab, select the correct configuration and version, which must be provided by the FPOC or TPOC requesting the action.

17. Check the ‘Latest Version’ box to see only the latest version of all configurations.  

18. Use the ‘Filter’ field below the configuration list to refine the list and show a subset of configurations (e.g. Type in ‘DCW’ and see only those configurations beginning with DCW).

19. Select (click on) the correct configuration from the list

20. Click the right pointing arrow button in the middle of the ‘Edit Specification’ window to add the new rule or configuration to the workarea specification

21. Click ‘OK’

22. Click ‘Finish’

Create a Workarea based on a configuration:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Workarea Wizard …’

3. In the Default window, select ‘Create a custom workarea’

4. In the Customize window, type in the workarea name 

5. Type in the description of what the workarea will be used for

6. Click ‘Next’

7. In the Default Check in Branch window, if a default check-in branch has been requested, select the correct branch name by clicking on it once  [NOTE: If no default check-in branch is selected, objects are checked-in to the branch from which they were checked-out]

8. Click ‘Next’

9. On the ‘Configurations’ tab, select the correct configuration and version, which must be provided by the FPOC or TPO requesting the action.

10. Check the ‘Latest Version’ box to see only the latest version of all configurations.  

11. Use the ‘Filter’ field below the configuration list to refine the list and show a subset of configurations (e.g. Type in ‘DCW’ and see only those configurations beginning with DCW).

12. Select (click on) the correct configuration from the list

13. Click the right pointing arrow button in the middle of the ‘Edit Specification’ window to add the new rule or configuration to the workarea specification

14. Select ‘Latest (MAIN)’ on the right hand list

15. Click the left pointing arrow button in the middle of the “Edit Specification’ window to remove the rule from the workarea specification

16. Click ‘OK’

17. Click ‘Finish’

Create a Workarea Specification File Manually:

1. Open Notepad

2. Type one rule on each line

3. Use the following examples for each rule to create the list of rules you want to use in your workarea, substituting the correct object and container names, branches, versions and dates for everything in italics

4. All dates use the format DD-MON-YY

· LATEST(Branch)

· INCLUDE_FOLDER(ContainerName{Branch;version}=Folder)

· EXCLUDE_FOLDER(ContainerName{Branch;version}=Application System)

· INCLUDE_CONFIG(ConfigurationName{Branch;version}=Configuration)

· INCLUDE_OBJECT(ConfigurationName{ContainerBranch;version}/ObjectName{ObjectBranch;version}=Object Type)

· FOLDER_LATEST_BEFORE(ContainerName{Branch;version}=Application System,date)

· FOLDER_LATEST_BETWEEN(ContainerName{Branch;version}=Application System,StartDate,EndDate)

· FOLDER_LATEST_CONTENTS(ContainerName{Branch;version}=Application System,Branch)

· LATEST_BEFORE(Branch,date)

· LATEST_BETWEEN(Branch,StartDate,EndDate)

· LATEST_CONFIG_CONTENTS(Branch,ConfigurationName{ConfigurationBranch;version}=Configuration)

· LATEST_DIAGRAM_CONTENTS(ContainerName{ContainerBranch;version}/DiagramName{DiagramBranch;version}=Diagram,DiagramContentsBranch
5. Select File menu, Save

6. Change ‘Save as type:’ to ‘All Files’

7. Put in the specification file name including ‘cws’ as the file extension

8. Click ‘Save’

Create a Workarea based on a specification file:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Workarea Wizard …’

3. In the Default window, select ‘Create a workarea based on a file stored workarea specification’

4. In the File Specification window, type in the workarea name 

5. Type in the description of what the workarea will be used for

6. Click the ‘Browse’ button

7. Locate and select the specification file (will always end in ‘cws’)

8. Click ‘Open’ in the ‘Select specification file’ window

9. Click ‘Next’

10. In the Default Check in Branch window, if a default check-in branch has been requested, select the correct branch name by clicking on it once  [NOTE: If no default check-in branch is selected, objects are checked-in to the branch from which they were checked-out]

11. Click ‘Next’

12. Click ‘Finish’

Create a Workarea Specification file from an existing workarea:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Select the ‘Edit’ menu, ‘Edit Workarea …’

7. On the ‘Specification’ tab, click the ‘Save to file …’ button

8. Name the specification file you’re creating

9. Click ‘Save’

10. Click ‘Cancel’ to close the Workarea Edit Window

Grant/Remove Access to a Workarea:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open’

3. Click the ‘Up One Level’ button (yellow folder with up arrow) until the word ‘Repository’ shows in the Navigator window

4. Select ‘Repository’

5. Click ‘OK’

6. Expand the ‘Shared Workareas’ list

7. Select the correct workarea

8. Select the ‘File’ menu, ‘Access Rights’, ‘Grant Access Rights …’

9. Select the user to provide access to (hold down the ‘Ctrl’ key to select multiple names)

10. To grant access, check the correct boxes in ‘To Grant’ for the access being granted

11. Click ‘Grant’

12. To remove access, check the correct boxes in ‘To Revoke’ for access being removed

13. Click ‘Revoke’

14. Click ‘OK’

Checkout objects

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Expand the container the object is in

7. Expand the object type identifier

8. Select the correct object to be checked-out (hold down the ‘Ctrl’ or ‘Shift’ key to select multiple objects)

9. Select the ‘Version’ menu, ‘Check Out …

10. In the ‘Check Out’ window, type in ‘Check out notes:’, such as “SCR#”

11. Click ‘OK’

Check-in objects

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Expand the container the object is in

7. Expand the object type identifier

8. Select the correct object to be checked-in (hold down the ‘Ctrl’ or ‘Shift’ key to select multiple objects)

9. Select the ‘Version’ menu, ‘Check In …

10. In the ‘Check In’ window, under ‘Options for …’ 

· The current check-in branch is displayed with the option to select another branch.  If you’ve made changes for a new release, change the check-in branch to the appropriate one in the drop down box.

· You can select to ‘Use check out notes’.

· You can choose to “Check out after Check-in”, which may be needed if a new release version of an object is being created prior to release changes being made to the object.

· Only use “Check in even if unchanged’ when a object is being branched to create a version for a new release prior to release changes being made.

11. If you didn’t select the “Use check out notes’ box, type in ‘Check in notes:’

12. Click ‘OK’

13. If a message window pops up that says, “There is some number object that is unchanged since check out.  Continue and check in?”, Click ‘Cancel’

14. If you’re checking in more than one object at a time, check-in each separately to find which one hasn’t been changed and perform an ‘Undo checkout’ on the unchanged object.

Check-in objects with merge

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Expand the container the object is in

7. Expand the object type identifier

8. Select the correct object to be checked-in (hold down the ‘Ctrl’ or ‘Shift’ key to select multiple objects)

9. Select the ‘Version’ menu, ‘Check In …

10. In the ‘Check In’ window, either check the ‘Use check out notes’ box or type in ‘Check in notes:’

11. Click ‘OK’

12. If a message window pops up that says, “There is some number object that is unchanged since check out.  Continue and check in?”, Click ‘Cancel’

13. If you’re checking in more than one object at a time, check-in each separately to find which one hasn’t been changed and perform an ‘Undo checkout’ on the unchanged object.

14. If a message window pops up that says, “There is 1 object that needs to be merged”, Click ‘OK’

15. Select ‘Use merge window’

16. Click ‘OK’

17. In the merge window, the single right arrow goes to the next difference between the merging objects and the double right arrow goes to the next conflict.

18. At each conflict, click in the select box next to the version to choose the meta-data wanted in the target.  When selection is made the specific meta-data is displayed under the object; both versions can be selected to easily see the differences in meta-data.  

19. When all selections are made, click ‘Save’ at the bottom of the window

Undo Checkout of objects

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Expand the container the object is in

7. Expand the object type identifier

8. Select the correct object to undo the checkout (hold down the ‘Ctrl’ or ‘Shift’ key to select multiple objects)

9. Select the ‘Version’ menu, ‘Undo Checkout …

10. Click ‘OK’

Version and Modify a Configuration based on specific requests:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Configuration Wizard …’

3. Select ‘Create a new version of an existing configuration’

4. Click the ‘Browse’ button

5. Select the correct configuration

6. Click ‘OK’

7. Type in ‘Check out notes:’

8. In the Check out window, click ‘OK’

9. In the Options window, select ‘Refine existing configuration’

10. In the Members window, 

11. To add a Member, click the ‘Add Member …’ button

· In the Add Configuration members window, you may change the Type of object using the drop down box to select a specific object type and shorten the number of objects listed

· If needed, click the ‘Up One Level’ button to find the list of workareas of containers

· Double-click to select the workarea or container you wish to search for the object

· Select the correct object(s), you can also select a specific version of the object by using the Version drop down box

· Click ‘OK’

· Click ‘Yes’ to add container context

12. To delete a Member

· Select the object(s) to remove from the configuration

· Click the ‘Remove Member’ button

13. To change the version of a member

· Select the object you need the new version of

· Click the ‘Change Version’ button

· Select the correct version of the object

· Click ‘OK’

14. Click ‘NEXT’

15. In the External References window, click ‘NEXT’

16. In the Save window, select ‘Save and check in configuration’

17. Click ‘NEXT’

18. In the Check in window, type in ‘Check in Notes’; will usually be something like ‘Configuration versioned to add/delete/change version of objects per … request’

19. Make sure the Use Branch is set to MAIN

20. Click ‘OK’

21. Click ‘Finish’

Version and Modify a Configuration based on a Workarea:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Configuration Wizard …’

3. Select ‘Create a new version of an existing configuration’

4. Click the ‘Browse’ button

5. Select the correct configuration

6. Click ‘OK’

7. In the Check out window, click ‘OK’

8. In the Options window, select ‘Re-create configuration from a workarea’

9. Type in the Workarea Name 

10. Normally select ‘From current contents’, unless otherwise requested

11. In the Options window, click ‘NEXT’

12. In the Members window, click ‘NEXT’

13. In the External References window, click ‘NEXT’

14. In the Save window, select ‘Save and check in configuration’

15. Click ‘NEXT’

16. In the Check in window, type in ‘Check in Notes’; will usually be something like ‘Configuration versioned to add/delete/change version of objects per … request’

17. Make sure the Use Branch is set to MAIN

18. Click ‘OK’

19. Click ‘Finish’

Version and Modify a Configuration based on the latest version of each object in the configuration:

1. Open the Repository Object Navigator (RON)

2. Select the ‘Tools’ menu, ‘Configuration Wizard …’

3. Select ‘Create a new version of an existing configuration’

4. Click the ‘Browse’ button

5. Select the correct configuration

6. Click ‘OK’

7. In the Check out window, click ‘OK’

8. In the Options window, select ‘Refresh all existing members with their latest versions’

9. Select ‘Preview refresh list’

10. Click ‘Next’

11. In the Refresh list window, click ‘Select All’ button, or select individual objects

12. Click ‘Refresh’

13. In the Members window,  click ‘Next’

14. In the External References window, click ‘NEXT’

15. In the Save window, select ‘Save and check in configuration’

16. Click ‘NEXT’

17. In the Check in window, type in ‘Check in Notes’; will usually be something like ‘Configuration versioned to add/delete/change version of objects per … request’

18. Make sure the Use Branch is set to MAIN

19. Click ‘OK’

20. Click ‘Finish’

Edit Workarea Rules and Specifications based on specific requests:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Select the ‘Edit’ menu, ‘Edit Workarea …’

7. On the ‘Properties’ tab you can change the workarea name and description by typing in the correct fields.

8. Click the ‘Finish’ button if you’re done, or the ‘Next’ button to continue editing the workarea

9. On the ‘Checkin Branch’ tab you can change the default check-in branch by selecting the correct branch

10. Click the ‘Finish’ button if you’re done, or the ‘Next’ button to continue editing the workarea

11. On the ‘Specification’ tab you can change the rules that define what objects appear in a workarea.

12. To change the workarea specifications, click on the ‘Edit …’ button

13. On the ‘Rules’ subtab, select the correct Rule from the drop down box.  The FPOC or TPOC requesting the action must provide the rules and all parameters for them.  The rules and their parameters are:

· Exclude Folder – Folder Path

· Exclude Object – Object Path

· Include Folder – Folder Path

· Include Object – Object Path

· Folder Latest Contents – Folder Path, Branch Label

· Latest – Branch Label

· Latest config contents – Branch Label, Configuration

· Folder Latest Before – Folder Path, Before Date

· Folder Latest Between – Folder Path, Start Date, End Date

· Latest Before – Branch Label, Before Date

· Latest Between – Branch Label, Start Date, End Date

· Latest Diagram Contents – Diagram Path, Branch Label

14. Select (click on) the correct rule, and use the ‘Browse’ buttons to locate the correct parameters required for that rule.

15. For Folder, Object and Diagram Path parameters, clicking the ‘Browse’ button brings up a ‘Select folder/object/diagram Path:’ window.  By default, this window only displays what’s in the current workarea.  To look in a different workarea or container: At the top middle of the window is a button with a yellow folder and an upward pointing arrow on it.  Click on this button to go up one level in the repository structure, keep clicking until you see the selection list displaying Private Workareas, Shared Workareas, Configurations, All Containers.

16. Depending on whether you’re looking in a workarea or a specific version of a container for your object, double click on that selection (the FPOC/TPOC should identify exactly where to find the objects they want included).

17. Keep double clicking on the appropriate workarea, and then containers until you get to the level you need to find the correct object.

18. Select the identified object with a single click, then click ‘OK’

19. On the ‘Configurations’ subtab, select the correct configuration and version, which must be provided by the FPOC or TPOC requesting the action.

20. Check the ‘Latest Version’ box to see only the latest version of all configurations.  

21. Use the ‘Filter’ field below the configuration list to refine the list and show a subset of configurations (e.g. Type in ‘DCW’ and see only those configurations beginning with DCW).

22. Select (click on) the correct configuration from the list

23. Click the right pointing arrow button in the middle of the ‘Edit Specification’ window to add the new rule or configuration to the workarea specification

24. To remove a rule or configuration from the workarea specification, select it from the list on the right side of the window, then click the left pointing arrow button in the middle of the ‘Edit Specification’ window.

25. Click ‘OK’

26. Click ‘Finish’

27. If the change requires a workarea refresh, see that set of instructions beginning with step 7.

Edit Workarea Rules and Specifications based on a specification file:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Select the ‘Edit’ menu, ‘Edit Workarea …’

7. On the ‘Properties’ tab you can change the workarea name and description by typing in the correct fields.

8. Click the ‘Finish’ button if you’re done, or the ‘Next’ button to continue editing the workarea

9. On the ‘Checkin Branch’ tab you can change the default check-in branch by selecting the correct branch

10. Click the ‘Finish’ button if you’re done, or the ‘Next’ button to continue editing the workarea

11. On the ‘Specification’ tab you can change the rules that define what objects appear in a workarea.

12. To change the workarea specifications, click on the ‘Load from file …’ button

13. Locate and select the specification file (will always end in ‘cws’)

14. Click ‘Open’ in the ‘Select specification file’ window

13. Click ‘Finish’

14. If the change requires a workarea refresh, see that set of instructions beginning with step 7.

Refresh a Workarea:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Select the ‘Edit’ menu, ‘Refresh Workarea’

7. Check the ‘Preview changes before refreshing’ box to review changes that are being made.  

8. Click ‘OK’

9. In the ‘Preview Change in workarea before refreshing’ window there are three tabs.

10. ‘New’ tab lists all objects to be added to the workarea

11. ‘Changed’ tab lists all objects in the workarea where you’re changing the version

12. ‘Removed’ tab lists all objects to be removed from the workarea

13. Check the lists at each tab to ensure the correct objects are being added, removed or changed

14. Click ‘OK’

Comparing different versions of an object:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the correct workarea

5. Click ‘OK’

6. Expand the container the object is in

7. Expand the object type identifier

8. Select the object you want to compare 

9. Select the ‘Version’ menu, ‘Compare Previous Version …’ to find the changes made to the current version of the object

10. Compare window opens with the older version on the left and the new version on the right.  Changes are color-coded.  Click the ‘x’ in the upper right corner to close the compare window.

11. Or, Select the ‘Version’ menu, ‘Compare other Version …’ to find all differences between those two versions of the object

12. In the ‘Select other Version for Compare’ window, select the version you want to compare to

13. Click ‘OK’

14. Compare window opens with the older version on the left and the new version on the right.  Changes are color-coded.  To see only the differences, click the ‘Show Differences’ button (third button from the left at the top).  Click the ‘x’ in the upper right corner to close the compare window.

Comparing different versions of a configuration:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. At the top middle of the window is a button with a yellow folder and an upward pointing arrow on it.  Click on this button to go up one level in the repository structure, to the Navigator View.

4. Select ‘Repository’ (with single click)

5. Click ‘OK’

6. Expand ‘Configurations’

7. Expand the configuration to display all versions

8. Select the configuration version you want to compare 

9. Select the ‘Version’ menu, ‘Compare Previous Version …’ to find the changes made to the current version of the object

10. Compare window opens with the older version on the left and the new version on the right.  Changes are color-coded.  Click the ‘x’ in the upper right corner to close the compare window.

11. Or, Select the ‘Version’ menu, ‘Compare other Version …’ to find all differences between those two versions of the object

12. In the ‘Select other Version for Compare’ window, select the version you want to compare to

13. Click ‘OK’

14. Compare window opens with the older version on the left and the new version on the right.  Changes are color-coded.  To see only the differences, click the ‘Show Differences’ button (third button from the left at the top).  Click the ‘x’ in the upper right corner to close the compare window.

Comparing different objects:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. At the top middle of the window is a button with a yellow folder and an upward pointing arrow on it.  Click on this button to go up one level in the repository structure, to the Navigator View.

4. Select ‘Repository’ (with single click)

5. Click ‘OK’

6. Expand the object type you want to compare, workarea, configuration, container, or individual object

7. Keep expand the display until you locate the appropriate object and version

8. Select the ‘Utilities’ menu, ‘Compare …’ 

9. In the ‘Select Second Object for Compare’ window, locate and select the object and version you want to compare to

10. Click ‘OK’

11. Compare window opens with the second object on the left and the original object on the right.  Changes are color-coded.  Click the ‘x’ in the upper right corner to close the compare window.

Merging Objects:

1. Open the Repository Object Navigator (RON)

2. Select the ‘File’ menu, ‘Open …’

3. Double-click to expand the ‘Shared Workareas’ list

4. Select the workarea with the target object version

5. Click ‘OK’

6. Select the object you want to merge to, may be container or other primary object 

7. Compare the source and target versions of the object you wish to merge so you know what the differences are and which you need in the final merged version

8. Ensure the source version is checked-in

9. Checkout the target object version

10. Select the ‘Version’ menu, then ‘Merge …’

11. In the ‘Select Source Version for Merge’ window, select the source object version

12. Click ‘OK’

13. In the ‘Merge Configuration’ window, check the displayed source and target object versions, if either are incorrect, click ‘Cancel’

14. In Merge Options, select ‘Use merge window’

15. Click ‘OK’

16. In the merge window, the single right arrow goes to the next difference between the merging objects and the double right arrow goes to the next conflict.

17. At each conflict, click in the select box next to the version to choose the meta-data wanted in the target.  When selection is made the specific meta-data is displayed under the object; both versions can be selected to easily see the differences in meta-data.  Check each difference to ensure the correct selections are checked.

18. When all selections are made, click ‘Save’ at the bottom of the window

19. After the merge window closes, select the target object of the merge

20. Select the ‘Version’ menu, ‘View Version History …’

21. There should be a line from under the source version to the top of the target version.  If the line is missing the merge didn’t work.

22. Close the Version History Viewer

23. Check-in the target object, ensuring the check-in branch is correct

Appendix C

Points of Contact

Title
Name
Phone

DCII Project Management Officer
Beth McGrath
(703) 607-5012

DCD/DCW Project Management Officer
Greg Williams
(317) 510-3135

DCII Technical Architect
Robyn Baker
(850) 453-4141 x663

DCII Technical Project Officer
Nancy Moore
(317) 510-5650

DCII Release Manager
Bill Farison
(317) 510-5654

DCII Configuration Manager
Bill Farison
(317) 510-5654

DCD/DCW CMIS Administrator
Linda Kidwell
(317) 510-2357

DCII Data Management
Stacy Simmons
(703) 607-1918

Repository Manager
Scott Spoelman
(317) 510-1467

DCII Integration Team Lead
Jan Bond
(317) 510-1846

DBA Team Lead
John Orton
(317) 510-3388

DCD Functional Point of Contact (FPOC)
Andy Moxley
(317) 510-1139

DCD Alternate FPOC
Ellen Lanier
(317) 510-4616

DCW FPOC
Ed McIntire
(317) 510-4300

DCW Alternate FPOC
Ray Stanley
(317) 510-5849


DCW FCM
Bryan Brown
(317) 510-5838

DCD Technical Project Officer (TPO)
Chad Bernholtz
(816) 926-2489

DCD Alternate TPO
Cathy Michaelis
(614) 692-9587

DCD Alternate TPO
CPT Floy Yates
(816) 926-5064

DCD Alternate TPO
Maggie Tompkins
(816) 926-1117

DCD Alternate TPO
Tracy Nelson
(614) 692-8084

DCD Alternate TPO
Kevin Cockrell
(614) 693-4956

DCW TPO
Dave Banton
(317) 510-5677

DCW Alternate TPO
Terri Newnam
(317) 510-2333

CSF POC
Fabio Dantas
(317) 510-6093

CSF Alternate POC
Ken Hetue
(317) 510-2312

Corporate Tool Set POC
Roger Hill
(317) 510-5988

System Security POC
Andy Moxley
(317) 510-1139

System Security Alternate POC
Ellen Lanier
(317) 510-4616

Webmethods POC
Juliann Smith
(614) 692-5217

Webmethods Alternate POC
Dave Fredo
(614) 692-8326

Appendix D

Forms and Web Sites

Title
Hyperlink



Location

6i Repository Container/Workarea Request Form

app chg

\\ISO-FS-N-1\DATA\dcii-shared\Templates-Forms\Repository_Forms\6i_appl_chg.DOC

6i Repository User Access Request Form
user chg

\\ISO-FS-N-1\DATA\dcii-shared\Templates-Forms\Repository_Forms\6i_user_chg.DOC

6i Repository Naming Standards
stds
http://www.dfas.mil/technology/pal/sestds/Standards3-6i.pdf
CM/RM Generation Procedures for 6I
gen inst

\\ISO-FS-N-1\DATA\dcii-shared\Work_Areas_Groups\Release-Management\Generation-Instructions\Object Generation Instr v2.doc

Configuration List script
obj list

\\ISO-FS-N-1\DATA\dcii-shared\Work_Areas_Groups\Release-Management\Generation-Instructions\objects_in_cfg.sql
Configuration Functional Compare script  
func comp

\\ISO-FS-N-1\DATA\dcii-shared\Work_Areas_Groups\Release-Management\Generation-Instructions\func_cfg_obj_compare.sql
Configuration Technical Compare script  
tech comp

\\ISO-FS-N-1\DATA\dcii-shared\Work_Areas_Groups\Release-Management\Generation-Instructions\dev_cfg_obj_compare.sql

DCII Standard Abbreviations and Acronyms
abbr

https://dm-app1.dfas.mil/Abrv

Sample Release Letter
rel ltr

\\ISO-FS-N-1\DATA\dcii-shared\Work_Areas_Groups\Release-Management\Generation-Instructions\ Release Letter Sample.doc
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